GATK error: CommandLineGATK : Unsupported major.minor version 51.0

If you see an error: CommandLineGATK : Unsupported major.minor version 51.0), while running new GATK, this means you most likely need newer java. Either:

  • Install the latest java with apt-get (if you have root access and Ubuntu/Debian)
  • sudo apt-get install oracle-java9-installer
  • Or download JRE from Oracle website and and set up system $PATH
    ie. if you have your JRE unpacked in ~/src/jre add these lines to your ~/.bashrc:
  • #java RE
    export PATH=~/src/jre/bin:$PATH
    

    And open new terminal window.

You can check installed JRE version with

java -version

The location of `java` binaries can be checked with

which java